Yamaha FZ16 Carburetor Problem, Power loss and sounds from exhaust

pr0ph3t

Expert
MOD
LV
2
 
Messages
741
Solutions
18
EXP
17,850
I bought a second-hand Yamaha FZ16 2014 model and since then there was slight missing and random power loss when I reduce the throttle and increase it. And occasionally there is a small exploding kinda sound from the exhaust. I showed It to a mechanic and he said the carburetor is fine and fixed the issue but it felt the same. Then took the bike to an authorized service center and after checking they told: "the choke cable inside the carburetor has rusted and is stuck, the carburetor should be replaced and cant be fixed".
Has any of you faced this issue? is there any workaround?
 


pr0ph3t

Expert
MOD
LV
2
 
Messages
741
Solutions
18
EXP
17,850
Just to let everyone know i was able to fix the issue with the carburettor. The choke piston was stuck inside the carburettor and was in an on state. So it's caused a serious mileage drop and power loss under 4000 RPM. I took it the nearest lathe and got it pulled out then replaced the choke piston and choke cable with a new one.

That solved the missing issue but there is a pop sound from the exhaust which i suspect is due to carbon deposit on the cylinder head.
 

Carthiq joshua

Registered
LV
0
 
Messages
1
EXP
0
Pls change the carburetor of pulsar 150 its suitable for Yamaha Fz16 and also you will get good mileage around 50kmpl
After changing the carburetor there no exhaust sound and power loss
 

pr0ph3t

Expert
MOD
LV
2
 
Messages
741
Solutions
18
EXP
17,850
Pls change the carburetor of pulsar 150 its suitable for Yamaha Fz16 and also you will get good mileage around 50kmpl
After changing the carburetor there no exhaust sound and power loss
But many people are saying there is power loss
 

Abhinav

Registered
LV
0
 
Messages
1
EXP
0
I bought a second-hand Yamaha FZ16 2014 model and since then there was slight missing and random power loss when I reduce the throttle and increase it. And occasionally there is a small exploding kinda sound from the exhaust. I showed It to a mechanic and he said the carburetor is fine and fixed the issue but it felt the same. Then took the bike to an authorized service center and after checking they told: "the choke cable inside the carburetor has rusted and is stuck, the carburetor should be replaced and cant be fixed".
Has any of you faced this issue? is there any workaround?
Bro..I own an FZ16 and facing same issue from last 6 months.I showed its to mechanics but they adjust fuel mixture ratio but problem is still same with the FZ...What should I do?
 

pr0ph3t

Expert
MOD
LV
2
 
Messages
741
Solutions
18
EXP
17,850
Bro..I own an FZ16 and facing same issue from last 6 months.I showed its to mechanics but they adjust fuel mixture ratio but problem is still same with the FZ...What should I do?
This was my issue:
Just to let everyone know i was able to fix the issue with the carburettor. The choke piston was stuck inside the carburettor and was in an on state. So it's caused a serious mileage drop and power loss under 4000 RPM. I took it the nearest lathe and got it pulled out then replaced the choke piston and choke cable with a new one.

That solved the missing issue but there is a pop sound from the exhaust which i suspect is due to carbon deposit on the cylinder head.

So check your choke cable and see if it's wrong, if not then it might be something else.


General tips are to clean carb and CDI unit.
 

Topics You Missed

Advertisement

Latest Posts